GRE隧道跨域OSPF组播互联

图片[1]-GRE隧道跨域OSPF组播互联-Rain's Blog

要求:PC4与PC5为不同的内网,无法访问公网(100.1.1.0/24段),需要在两台出口路由MSR36-20_1与 MSR36-20_3设置隧道连接以完成跨地域内网互联, MSR36-20_2模拟公网路由。

首先连通 MSR36-20_1 与 MSR36-20_3

MSR36-20_1 配置

interface GigabitEthernet 0/1
ip address 100.1.1.2 24
quit
interface GigabitEthernet 0/0
ip address 192.168.1.1 24
quit
ip route-static 0.0.0.0 0 100.1.1.1
write

MSR36-20_2 配置

interface GigabitEthernet 0/1
ip address 100.1.1.1 24
quit
interface GigabitEthernet 0/2
ip address 192.168.2.1 24
quit
write

MSR36-20_3 配置

interface GigabitEthernet 0/0
ip address 100.1.2.2 24
quit
interface GigabitEthernet 0/2
ip address 192.168.2.1 24
quit
ip route-static 0.0.0.0 0 100.1.2.1
write

此时, MSR36-20_1 与 MSR36-20_3应可以互通

搭建GRE隧道

MSR36-20_1 配置

interface Tunnel 0 mode gre
ip address 10.0.0.1 24
source 100.1.1.2
destination 100.1.2.2
quit

MSR36-20_3 配置

interface Tunnel 0 mode gre
ip address 10.0.0.2 24
source 100.1.2.2
destination 100.1.1.2
quit

此时,互相ping对方隧道IP(10.0.0.0/24段)应畅通

创建OSPF宣告

MSR36-20_1 配置

ospf 1
area 0
network 10.0.0.0 0.0.0.255
network 192.168.1.0 0.0.0.255

MSR36-20_3配置

ospf 1
area 0
network 10.0.0.0 0.0.0.255
network 192.168.2.0 0.0.0.255

此时,OSPF宣告完成,输入display ip routing-table,可见通过OSPF获取到了对方的内网路由表

图片[2]-GRE隧道跨域OSPF组播互联-Rain's Blog
图为 MSR36-20_3 成功建立OSPF后的路由表,可见有优先级为10的OSPF路由

PC4与PC5分别配置IP、掩码与网关,此时,两台主机应可以互相ping通。

© 版权声明
THE END
喜欢就支持一下吧
点赞0赞赏
分享
评论 抢沙发
Rain的头像-Rain's Blog

昵称

取消
昵称表情代码图片